/ OSS / Vim-Plug-In sslsecure hilft bei der Konfiguration von SSL/TLS-Servern

Vim-Plug-In sslsecure hilft bei der Konfiguration von SSL/TLS-Servern

ssl-secure-vim-e022df7ab89969e1.png
Moritz Rosenfeld on June 1, 2017 - 9:54 am in OSS

Ein Plug-In für den Texteditor Vim zeigt in Konfigurationsdateien SSL-Cypher-Suiten an, die gefährlich sind. Das kann fatale Fehlkonfigurationen verhindern.

Die Konfiguration von SSL/TLS-Servern ist knifflig. Selbst Experten vom Fach machen da gern schon mal den einen oder anderen Fehler, dessen Folgen fatal sein können. Besonders haarig kann das Einstellen der richtigen Cypher-Suiten werden, da nicht alle wählbaren Optionen für sichere Verbindungen sorgen. Das Plug-In sslsecure für den beliebten Unix-Texteditor Vim verspricht Abhilfe. Es markiert automatisch die unsicheren Optionen in knackigem Rot.

Das Plug-In funktioniert mit jeder Art Text-Datei – sowohl für die Konfigurationsdateien von Web-Servern, Mail-Servern, also auch für Programmiersprachen und Datenbankserver. Außerdem funktioniert es mit OpenSSL und mit LibreSSL. Mehr Informationen liefert das Blog des Entwicklers. Ein Tipp noch zum Abschluss: Wer aus Vim nicht mehr raus kommt, dem hilft Stack Overflow. (fab)

Read more on: Source

Comments are disabled